CAPIF DEPLOYMENT: network services_default not found

Operating system: macOS Monterey
version 12.6.1
Applications: Docker Desktop, Visual Studio Code

In the CAPIF deployment, after running the command << ./ >>, it printed this error:


As a result, the container was created but it could’t start.

SOLUTION: before deployment, I manually created network services_default by running:


After that, I run <<./>> and worked!

Hello Alex.
I can not see on your post the error that you mention. Could you please send it again?


The error was : network services_default not found

It means that the ./ didn’t create the network

The solution is : docker create network services_default

I created manually the network, before ./ and fixed it

Did you run on this problem from the first time that you deployed CAPIF?

Yes, from the first time.

If you delete all containers, networks, volumes etc, and start a clean deployment of the CAPIF, does the same error appear?

I deleted all containers and volumes for troubleshooting, but not the networks, and it showed the same error.