NEF_emulator_error: network-services-default not found

Trying to setup CAPIF + NEF (locally for now) for the IMM NetApp

Error when trying to run the NEF emulator:
network services_default declared as external, but could not be found


Steps to reproduce:

  1. Clone the CAPIF repo,

  2. Go to services folder

  3. Run the ./ command, then check its result. Unclear if everything is fine or not.

  4. Clear everything related to the NEF emulator container

  5. Complete the /etc/hosts file with capifcore line (using localhost)

  1. Set EXTERNAL_NET=true in the env-for-local-dev file, then copy it to .env
  2. Re-build NEF emulator (without cache), then try to run it

Host environment:

  • Windows 10
  • Git bash
  • Docker-for-Windows
  • NEF emulator 1.6.1
  • Last CAPIF version (develop branch)

Potential origin of the issue: not using sudo when running the ./ script? Sudo is not available in git bash for Windows, but I will investigate in this direction for now. Am I missing something else?

Edit: I installed this to be able to run sudo commands, but it led to the same result.

Thank you in advance!

Hi Charles,

I have tried the CAPIF installation in Windows and I didn’t receive any errors. I would like to know more details about your host environment. From my side, I can say the following:

windows 10 version 21H2 compilation 19044.2251
Git bash version
Mobaxterm version 21.5 compilation 4826
Docker for windows

  • Client version 20.10.16
  • Server version 4.9.0 compilation 80466

So, using this environment I did not have any problem deploying CAPIF in Windows.

1 Like

Just to reflect here the mails exchanged with Ricardo:
We did not found the exact origin of the issue. However, I was not able to reproduce it on my other Windows laptop (with similar configuration).

I will thus continue to work on my laptop. Problem not solved but avoided :slight_smile:
Thank you Rachel and Ricardo.